ADL: AutoDockTools linux start software bug

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

ADL: AutoDockTools linux start software bug

Academic Research
I have Ubuntu 17.04 and I installed AutoDockTools as follows:

sudo apt update


sudo apt full-upgrade


sudo apt install autodocktools

I attempt to run the program by typing autodocktools  in the terminal but I get the following error: ImportError: No module named oldnumeric


I tried the following:


python -m pip install oldnumeric

pip install numpy==1.8.2

Now I get this Error:

ImportError: numpy.core.multiarray failed to import


I talked to some people in the irc.freenode.net #bioinformatics channel and it seems this bug has never been fixed since 2014: https://bugs.launchpad.net/ubuntu/+source/autodocktools/+bug/1640586


Has AutoDockTool been replaced by another program? What is it? if not, then how can I install and run AutoDockTool on linux Ubuntu 17.04?

Regards,

AC Research
________________________________________________
--- ADL: AutoDock List  --- http://autodock.scripps.edu/mailing_list ---
Reply | Threaded
Open this post in threaded view
|

Re: ADL: AutoDockTools linux start software bug

Leandro Bortot
Hello,

     I recently installed AutoDockTools on my Kubuntu 17.04.

     I had the "No module named oldnumeric" issue and fixed it by
downgrading numpy, as you did. But then everything worked for me.

     One possible difference is that I installed AutoDockTools myself using
a .tar.gz file downloaded from the official website. Maybe there is
something wrong with the repository version?

     Also, I'm really only using ADT's scripts directly (I don't even know
what the command "autodocktools" is supposed to do). Maybe that's the
reason why I didn't have the problem/bug you reported.

Best regards,
Leandro



On Sun, Aug 27, 2017 at 10:45 AM, Academic Research <[hidden email]>
wrote:

> I have Ubuntu 17.04 and I installed AutoDockTools as follows:
>
> sudo apt update
>
>
> sudo apt full-upgrade
>
>
> sudo apt install autodocktools
>
> I attempt to run the program by typing autodocktools  in the terminal but
> I get the following error: ImportError: No module named oldnumeric
>
>
> I tried the following:
>
>
> python -m pip install oldnumeric
>
> pip install numpy==1.8.2
>
> Now I get this Error:
>
> ImportError: numpy.core.multiarray failed to import
>
>
> I talked to some people in the irc.freenode.net #bioinformatics channel
> and it seems this bug has never been fixed since 2014:
> https://bugs.launchpad.net/ubuntu/+source/autodocktools/+bug/1640586
>
>
> Has AutoDockTool been replaced by another program? What is it? if not,
> then how can I install and run AutoDockTool on linux Ubuntu 17.04?
>
> Regards,
>
> AC Research
> ________________________________________________
> --- ADL: AutoDock List  --- http://autodock.scripps.edu/mailing_list ---
________________________________________________
--- ADL: AutoDock List  --- http://autodock.scripps.edu/mailing_list ---