ADL: problem in opening autodocktools

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

ADL: problem in opening autodocktools

leila karami
Dear autodocktools users

I installed following programs on windows:

First:python-2.7.3
Second:autodocksuite-4.2.5.1-i86Windows
third:mgltools_win32_1.5.6_Setup
fourth:autodock_vina_1_1_2_win32

After the installation, I used autodocktools 3 or 4 times.

When I start AutoDockTools for the fifth time, I encountered
with following message in python shell windows:
---------------------------------------------------------------------------------------------------------------------
Python 2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit
(Intel)] on win32
Type "copyright", "credits" or "license()" for more information.

    ****************************************************************
    Personal firewall software may warn about the connection IDLE
    makes to its subprocess using this computer's internal loopback
    interface.  This connection is not visible on any external
    interface and no data is sent to or received from the Internet.
    ****************************************************************

IDLE 1.2.2      ==== No Subprocess ====
>>> Traceback (most recent call last):
  File "C:\Program
Files\MGLTools-1.5.6\lib\site-packages\AutoDockTools\__init__.py", line
433, in runADT
    title=title, withShell= not interactive, verbose=False, gui=gui)
  File "C:\Program
Files\MGLTools-1.5.6\lib\site-packages\Pmv\moleculeViewer.py", line 843, in
__init__
    trapExceptions=trapExceptions)
  File "C:\Program
Files\MGLTools-1.5.6\lib\site-packages\ViewerFramework\VF.py", line 505, in
__init__
    self.userpref.loadSettings()
  File "C:\Program
Files\MGLTools-1.5.6\lib\site-packages\mglutil\preferences.py", line 138,
in loadSettings
    self.set(key, value)
  File "C:\Program
Files\MGLTools-1.5.6\lib\site-packages\mglutil\preferences.py", line 107,
in set
    cb(name,oldValue, value)
  File "C:\Program
Files\MGLTools-1.5.6\lib\site-packages\ViewerFramework\VF.py", line 732, in
startupDirPref_cb
    root = self.setUserPreference.form.root
AttributeError: SetUserPreference instance has no attribute 'form'
hit enter to continue
---------------------------------------------------------------------------------------------------------------------

First time I enconutered with this problem, I uninstalled all of above
programs.

Unfortunately, after 4 times using of autodocktools, again, I encontered
the same problem.

Is not my installation manner correct?

What is the reason of this problem?

Is there a problem about python?

Any help will highly appreciated.
________________________________________________
--- ADL: AutoDock List  --- http://autodock.scripps.edu/mailing_list ---
Reply | Threaded
Open this post in threaded view
|

Re: ADL: problem in opening autodocktools

jpc356
This post has NOT been accepted by the mailing list yet.
"SetUserPreference" appears to be an issue with the workspace folder not being a valid filename or not existing. If you can enter ADT, go to File>Set and set the workspace directory (preferably to something on the root drive to avoid any invalid characters in the pathname). If you cannot enter the program, you must determine the default workspace folder and create it, if necessary.

I would install AutoDock first and then install AutoDockTools (ADT) as it contains the python installer. I would be curious to see if your python installation is incompatible with ADT. I do not believe this is the case but it is worth testing. Please report back if you still have issues or if you manage to resolve the issue.
John Cahill
JPC356@Drexel.Edu
Undergraduate Researcher at Drexel University, Class of 2018

My posts do not reflect the views or knowledge base of Drexel University nor are they affiliated with the university.